Login issues - 03466934

Incident Report for Klara Service Status

Resolved

This issue is resolved.
Posted Aug 13, 2026 - 07:16 EDT

Investigating

We have reports of some users having difficulty logging in or delayed verification codes. We are investigating the issue.
Posted Aug 12, 2026 - 18:32 EDT
This incident affected: Web Browser Access and Mobility App.