KSO: 03128647 | Delay in Data for In-App Reports

Incident Report for Klara Service Status

Resolved

We’ve implemented a fix for the data connector issue that was causing delays in the Patient Engagement (Read Rate) and Staff Assignment Details reports. All report data is now updating as expected, and normal functionality has been restored.

Thank you for your patience while we worked to resolve this.
Posted Nov 06, 2025 - 08:38 EST

Investigating

We’re currently investigating an issue that’s causing some delays in data showing up for the following in-app reports:

- Patient Engagement (Read Rate)
- Staff Assignment Details

Our team has identified a problem with the data connector that processes this information and is actively working on a fix.

All other Klara features are working as expected. We’ll share another update as soon as the issue is resolved or if there are any significant changes.
Thank you for your patience while we work to restore full functionality.
Posted Nov 03, 2025 - 09:48 EST
This incident affected: Reporting.