Klara Performance Degradation - 03028396

Incident Report for Klara Service Status

Resolved

This issue is resolved.
Posted Aug 20, 2025 - 16:05 EDT

Monitoring

We have identified and resolved the issue, and are currently monitoring.
Posted Aug 20, 2025 - 13:05 EDT

Update

We have reports of performance issues within areas such as patient search, adding patients, etc... We are investigating and will update shortly.
Posted Aug 20, 2025 - 12:57 EDT

Investigating

We have reports that there are issues with searching within Klara, we are investigating and will update shortly.
Posted Aug 20, 2025 - 12:34 EDT
This incident affected: Other.