KLARA Slowness - 03093485

Incident Report for Klara Service Status

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 16:37 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 06, 2025 - 13:46 EDT

Investigating

Users may experience slower-than-usual performance when using KLARA. Our team is aware of the issue and is actively working to resolve it. We will provide updates as soon as more information is available.
Posted Oct 06, 2025 - 13:26 EDT
This incident affected: Web Browser Access.