Klara Unresponsive - 03317688

Incident Report for Klara Service Status

Resolved

This issue has been resolved.
Posted Apr 16, 2026 - 14:35 EDT

Monitoring

Our team has identified the issue and implemented a fix and functionality should be returning to normal. We will continue to monitor.
Posted Apr 16, 2026 - 14:00 EDT

Investigating

We have reports that Klara is unresponsive or extremely slow. We are working to identify the issue and will update soon.
Posted Apr 16, 2026 - 13:18 EDT
This incident affected: Web Browser Access, Mobility App, Messaging, Video Visits, Klara Website Widget, and Chrome Extension.