Login Issues - 03465897

Incident Report for Klara Service Status

Resolved

This issue is resolved.
Posted Aug 12, 2026 - 15:13 EDT

Monitoring

A fix has been implemented that should resolve the issue, we will continue to monitor.
Posted Aug 12, 2026 - 13:28 EDT

Investigating

We have reports that some users are seeing intermittent login issues where the login page does not load. We are investigating this issue further and will update shortly. Some users have reported success clearing cookies and caches.
Posted Aug 12, 2026 - 11:47 EDT
This incident affected: Web Browser Access.