Reporting is down - 03412398

Incident Report for Klara Service Status

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 14:17 EDT

Identified

We have found and are working on an issue regarding the reporting module. We will provide another update within an hour.
Posted Jul 01, 2026 - 13:58 EDT
This incident affected: Reporting.