Delayed Verification Codes - 03492413

Incident Report for Klara Service Status

Resolved

This issue is now resolved.
Posted Sep 02, 2026 - 08:04 EDT

Identified

This has been identified as an issue with our 3rd party provider. We will continue to work with them to come to a solution.
Posted Sep 01, 2026 - 16:47 EDT

Investigating

We have reports that verification codes (two factor emails) for login are delayed or not arriving. We are investigating the issue.
Posted Sep 01, 2026 - 12:53 EDT
This incident affected: Web Browser Access and Mobility App.